Enabling adb on Beaglebone Black

Asked by 6 months ago
I have successfully loaded TI-Android pre-built image on a BBB which was downloaded from here<http://downloads.ti.com/sitara_android/esd/TI_Android_DevKit/TI_Android_JB_4_2_2_DevKit_4_1_1/index_FDS.html>. Everything works well on the device. I have been trying to enable adb without much luck. Basic HW and SW is as follows *Hardware* - Beaglebone black. - 4DCAPE-43T. - 5V power supply. - mini usb connection to Ubuntu 12.04 LTS host system. *Software* - TI-Android JB image (TI_Android_JB_4.2.2_DevKit_4.1.1_beagleboneblack.tar.gz). - Ubuntu 12.04 LTS host system. On the BBB I have turned on USB debugging by - App Launcher" -> "Settings" -> "Developer options" On the Host side lsusb output is Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 001 Device 003: ID 0bda:0129 Realtek Semiconductor Corp. Bus 001 Device 004: ID 10f1:1a52 Importek */etc/udev/rules.d/51-android.rules* SUBSYSTEM=="usb", SYSFS{idVendor}=="18d1", MODE="0666" SUBSYSTEM=="usb", SYSFS{idVendor}=="0451", MODE="0666" I have executed the following two commands chmod a+r /etc/udev/rules.d/51-android.rules sudo service udev restart When I do an adb devices I don't see the BBB, but when I have HTC phone attached I do see a valid response. What I am doing wrong? Also I plug the mini-usb to the host machine. Is this correct? Or do I have connect to the serial debugging port. Thanks

Your Answer

Name:
Reply:

All Answers

Answer by 6 months ago
On Saturday, February 1, 2014 2:58:14 AM UTC+5:30, Mahendra Gunawardena wrote: Yes, you need to connect the mini-usb cable which came with BBB to access adb. Recheck the connections. You should get an entry for VID 18d1 once adbd is up on BBB. -Vishveshwar
Answer by 6 months ago
@Vishveshwar, I finally got the adb working on BBB. I have posted my results here<http://android.stackexchange.com/questions/62472/enabling-adb-on-beaglebone-black>
Answer by 6 months ago
Quoted message by Mahendra Gunawardena 6 months ago
@Vishveshwar, I finally got the adb working on BBB. I have posted my results here<http://android.stackexchange.com/questions/62472/enabling-adb-on-beaglebone-black>
On Sat, 1 Feb 2014 05:50:09 -0500 Mahendra Gunawardena Good info. How does jb422 run here? I know androids love memory.
Answer by 6 months ago
Quoted message by Mahendra Gunawardena 6 months ago
@Vishveshwar, I finally got the adb working on BBB. I have posted my results here<http://android.stackexchange.com/questions/62472/enabling-adb-on-beaglebone-black>
JB422 run well. No complains yet :-)